View Issue Details

IDProjectCategoryView StatusLast Update
0001149FreeCADBugpublic2015-02-25 11:08
Reporterpfirszt Assigned Toshoogen  
Status closedResolutionfixed 
Product Version0.13 
Fixed in Version0.15 
Summary0001149: Imposible to use wacom tablet
DescriptionI have a wacom intuos4 wl. FreeCad, in sketch editing mode, seems to be handling clicks ("left mouse button") in a special way, because it's impossible i.e. to select element using single click. When I click on an element in the drawing area cursor changes from arrow to hand, but instead of selecting an element the element if being moved.
Additional InformationIt might be related to "click & release" distance. Freecad seems to be expecting that click & release are in exactly the same point, which is impossible with tablet. Please let me know if you need more information about my system.
TagsNo tags attached.
FreeCAD Information


related to 0001717 closed Sketcher It is hard to move lines with digitizer pen. It is impossible to move points. 



2013-06-22 16:02

manager   ~0003236

Please provide complete info on FreeCAD version and operating system. This can be done easily by going to Help --> About FreeCAD. Click on "copy to clipboard" button and paste here.


2013-06-26 09:14

administrator   ~0003242

You want to do CAD on a tablet by touch?
Not a very common use case ;)


2013-06-26 09:58

developer   ~0003245

Not really - the tablet doesn't handle touch. I'll provide more info soon.
I'm using the tablet instead of mouse (including autocad/microstation/dialux on windows and blender/gimp/inkscape on linux). I actually don't use the mouse at all, so I hope we can fix the problem.


2013-06-26 19:39

developer   ~0003258

OS: Linux
Platform: 64-bit
Version: 0.13.$WCREV$
Python version: 2.7.3
Qt version: 4.8.4
Coin version: 2.5.0
SoQt version: 1.5.0

system: fedora F-18, updated

bash-4.2$ rpm -qi freecad
Name : freecad
Version : 0.13
Release : 1.1.fc18
Architecture: x86_64


2013-06-26 23:17

manager   ~0003261

It's odd that the revision number does not appear correctly. Did you compile yourself, or installed a pre-compiled package?


2013-06-27 18:11

developer   ~0003275

Yes, that's strange. It's from Fedora Fusion repository:
bash-4.2$ LC_ALL=c rpm -qi freecad
Name : freecad
Version : 0.13
Release : 1.1.fc18
Architecture: x86_64
Install Date: Wed May 22 20:43:44 2013
Group : Applications/Engineering
Size : 128420621
License : GPLv3+ with exception
Signature : RSA/SHA256, Thu Mar 7 12:56:54 2013, Key ID 90ce094be31b30ca
Source RPM : freecad-0.13-1.1.fc18.src.rpm
Build Date : Mon Mar 4 17:15:13 2013
Build Host :
Relocations : (not relocatable)
Packager : <>
Vendor : RPM Fusion
Summary : A general purpose 3D CAD modeler


2013-06-28 00:05

manager   ~0003278

Last edited: 2013-06-28 00:06

I've seen the same thing with the Mac OS X build, so it's a build configuration problem somehow.

If I'm not mistaken this Fedora package is not quite up to date... It's impossible to know without the revision number or the git commit.


2013-08-17 20:10

reporter   ~0003489

I confirm the same behaviour with my Wacom Intuos3 9x12 tablet using a STYLUS pen. I can't select any element by the pen tip (left mouse click).

Freecad compiled by myself from GIT repository a few days ago and here is a listing from Help -> About Freecad.

OS: Debian GNU/Linux 6.0.7 (squeeze)
Platform: 64-bit
Version: 0.13.2041 (Git)
Branch: master
Hash: fe19cb09cc7a07629ae224a64f58167780284987
Python version: 2.5.5
Qt version: 4.6.3
Coin version: 3.1.3
SoQt version: 1.4.2a
OCC version: 6.3.0

The same issue (I can't click by pen tip) I have with Krusader version 2.2.0-beta1 if I try to sort column listings. But any other software I use does not have problem with Wacom pen. So I think that there is problem with Freecad and Krusader as well in handling the left mouse clicks (too accurate mouse coordinates handling = ???). Because if you use tablet pen the cursor position changes before you just click on tablet because of hand is too curved and tablet has some proximity feature :-)

For example. If I use touchpad or trackpoint of my notebook (first move mouse cursor over an element and then click without any other cursor moving) selection works well. If I use Wacom pen to move cursor over the element then freeze my hand on that position and select the element by using touchpad or trackpoint left button the selection also works well. Finally if for moving and selection I use only the Wacom pen the moving works but selection doesn't. But it is strange that I can use drag&drop feature with Wacom pen. Only single click used for element selection does not work.

Recently I tried the Wacom tablet to be sure it works well at other CAD software. I used friends PC with Windows 7 + Autocad + SolidEdge and there wasn't any problem with it. So this looks like a bug in Freecad.


2013-08-17 20:34

manager   ~0003490

Last edited: 2013-08-17 20:35

Not in FreeCAD per se but in one of its third-party libraries. You said you have the same problem with Krusader which is a KDE-based package. Then it may be something with Qt libraries. I suggest you try to use it in another app that relies on Qt for its GUI.

If that's the case then it's out of FreeCAD devs power to fix.


2013-08-17 22:12

reporter   ~0003491

Thanks for quick response. Before the moment I tried to select some elements (lines and circles exactly) at LibreCAD. I think it is also QT based application. Here I provide LibreCAD details from its About section:

Version: 1.0.1
SCM Revision: 1.0.0
Compiled on: Mar 15 2012
Portions (c) 2011 by R. van Twisk
Program Icons Supplied by
   Pablo: LibreCAD Argentine
Splash and Logo supplied by
   Diego Daltom Designer

Modules: None

Main Website :

In Kursader I have that problem at one concrete situation (sort of file listing) otherwise the Wacom pen (its left mouse button click) and Krusader works together quite well.

Do you have any other suggestions or software I would have to test?


2013-08-17 22:44

reporter   ~0003492

Just update of information related to reported bug which can help. The problem in FreeCAD appears only if I try to select something (line, arc, point, distance etc.) in opened Sketch. If I try to select some edge at Part or Part Designer it is possible with Wacom tablet.


2013-08-19 04:33

administrator   ~0003494

Ok, its right, the selection of the sketcher is to fiddly. It goes to move-element if you move the mouse only one pixel while pressing left. Thats to eager, even if you use a standard mouse. I think we need at least a two pixel threshold before moving starts....


2015-01-08 06:51

manager   ~0005584

Hi all
does this issue still exist in current FreeCAD? I don't have a Wacom pad to test it.



2015-01-08 10:47

administrator   ~0005590

IMO, this ticket should stay open.


2015-02-17 22:56

developer   ~0005808

Please leave it open. My current system is fedora 21.
Version: 0.14
Revision number: $WCREV$
Release date: $WCDATE$
Word size: 64-bit

(Fedora still have the rev/rel problem)
$ rpm -qi freecad
Name : freecad
Version : 0.14
Release : 5.fc21
Architecture: x86_64

If you can point me (roughly, any variable or function name would be great) to where the problem might be in the code I'll try to fix it.


2015-02-21 15:14

administrator   ~0005816

Have a look at:

To check if the cursor hovers a geometry:


2015-02-23 19:03

developer   ~0005826

Selecting in the latest git version (f2d8fc91ec37081f3f0c283f43671573c4f58e70) works fine, but unselecting does not work as expected. Left click on an empty area using mouse causes deselection, but the same action with tablet does nothing. I'll try to narrow it down, but if you have any tips, please le me know.


2015-02-24 11:34

developer   ~0005827

Does your tabled allow you to hover with cursor?


2015-02-24 12:13

developer   ~0005828

Yes. Hovering is like moving mouse, touching the surface with the tip of the pen is like the left click and there is a rocker button oon the pen that works as right/middle click.
I can't find the place in the code where unselecting after "empty" left click takes place.


2015-02-24 20:26

developer   ~0005829

I did some more tests and the problem is now narrowed down to the sketch editing mode. In non-editing mode selecting/unselecting works fine for 3D objects and sketches.


2015-02-24 22:04

developer   ~0005830

Last edited: 2015-02-24 22:12

I would suspect that there is a mouse movement in between button1 press and button1 release. In this case you would enter rubber band selection mode.
maybe we need to add a threshold for the distance to active the rubberband mode, instead of enabling it on the first move event.


2015-02-24 22:33

developer   ~0005831

Last edited: 2015-02-24 22:34

could you please test if git:// sketcher-rubberband
( ) solves the problem for you.
Perhaps you might want to slightly increase the dragIgnoredDistance as well, if it does not work with the initial value.


2015-02-24 23:16

developer   ~0005832

Yes, that's it! There is no need to change te distance (at least for me with wacom intuos4 wireless), adding "case STATUS_SKETCH_StartRubberBand:" solves the problem. Thanks!

Related Changesets

FreeCAD: master ed80eb6c

2015-02-24 23:29:05


Details Diff
enter rubberband after moved by dragIgnoredDistance

issue 0001149
Affected Issues
mod - src/Mod/Sketcher/Gui/ViewProviderSketch.cpp Diff File

Issue History

Date Modified Username Field Change
2013-06-13 16:34 pfirszt New Issue
2013-06-22 16:02 normandc Note Added: 0003236
2013-06-26 09:14 Jriegel Note Added: 0003242
2013-06-26 09:14 Jriegel Status new => feedback
2013-06-26 09:58 pfirszt Note Added: 0003245
2013-06-26 19:39 pfirszt Note Added: 0003258
2013-06-26 23:17 normandc Note Added: 0003261
2013-06-27 18:11 pfirszt Note Added: 0003275
2013-06-28 00:05 normandc Note Added: 0003278
2013-06-28 00:06 normandc Note Edited: 0003278
2013-08-17 20:10 cejka Note Added: 0003489
2013-08-17 20:34 normandc Note Added: 0003490
2013-08-17 20:35 normandc Note Edited: 0003490
2013-08-17 22:12 cejka Note Added: 0003491
2013-08-17 22:44 cejka Note Added: 0003492
2013-08-19 04:33 Jriegel Note Added: 0003494
2013-08-19 04:33 Jriegel Status feedback => confirmed
2013-08-28 18:31 Jriegel Status confirmed => assigned
2013-08-28 18:31 Jriegel Assigned To => Jriegel
2015-01-08 06:51 jmaustpc Note Added: 0005584
2015-01-08 10:47 wmayer Note Added: 0005590
2015-02-17 22:56 pfirszt Note Added: 0005808
2015-02-21 15:14 wmayer Note Added: 0005816
2015-02-23 19:03 pfirszt Note Added: 0005826
2015-02-24 11:34 shoogen Note Added: 0005827
2015-02-24 12:13 pfirszt Note Added: 0005828
2015-02-24 20:26 pfirszt Note Added: 0005829
2015-02-24 22:04 shoogen Note Added: 0005830
2015-02-24 22:12 shoogen Note Edited: 0005830
2015-02-24 22:33 shoogen Note Added: 0005831
2015-02-24 22:33 shoogen Status assigned => feedback
2015-02-24 22:34 shoogen Note Edited: 0005831
2015-02-24 23:16 pfirszt Note Added: 0005832
2015-02-24 23:16 pfirszt Status feedback => assigned
2015-02-25 10:20 shoogen Relationship added related to 0001717
2015-02-25 10:59 shoogen Changeset attached => FreeCAD Master master ed80eb6c
2015-02-25 11:08 shoogen Status assigned => closed
2015-02-25 11:08 shoogen Assigned To Jriegel => shoogen
2015-02-25 11:08 shoogen Resolution open => fixed
2015-02-25 11:08 shoogen Fixed in Version => 0.15