View Issue Details

IDProjectCategoryView StatusLast Update
0001502FreeCADBugpublic2014-04-08 15:10
ReporterFleder Assigned Towmayer  
Status closedResolutionfixed 
PlatformPCOSWindowsOS Version7 64bit
Product Versiontrunk 
Fixed in Version0.14 
Summary0001502: crash when using "move" tool in part workbench

i made a custom toolbar consisting of align and move tools from the draft workbench, in my part workbench, so i could move 3d objects around and align them perfectly.

i can click on the move tool but if i click on the object afterwards the program always crashes.

this happens in the latest developers version of 0.14, no matter if i use 32bit or 64bit FreeCAD.
Steps To Reproduce- go to draft workbench first, then
- go to part workbench
- create custom toolbar with "move" tool in it
- have any object on your workbench
- click on move tool
- click on object
- crash
Additional InformationOS: Windows 7
Platform: 32-bit (also tried 64bit because of my OS)
Version: 0.14.3343 (Git)
Branch: libpack
Hash: 8dcb8f68cf17ef152d34d226d7699c98c5bb59fb
Python version: 2.7.6
Qt version: 4.8.5
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.7.0
TagsNo tags attached.
FreeCAD Information



2014-04-07 12:34

administrator   ~0004538

And this crash does not happen when using the Move tool when the Draft workbench is active?


2014-04-07 15:42

reporter   ~0004539

Last edited: 2014-04-07 15:44

This only happens in Part Workbench, Draft works fine.
And only on Windows, i tried it at work with the latest "unstable" build and it worked, too, without a crash.
Stable Version 0.13 works fine, too, on Windows in both, Draft and Part WB.


2014-04-07 16:35

administrator   ~0004540

Sounds very weird. I tried it too but got no crash. Could you please attach the files:
+ FreeCAD.log (to get this file start FreeCAD with the option --write-log)
+ crash.dmp

Both files are under %APDDATA%\FreeCAD You can copy & paste this as it is into the address bar of the Windows Explorer.


2014-04-07 16:45


FreeCAD.log (Attachment missing)


2014-04-07 16:48

reporter   ~0004541

Last edited: 2014-04-07 16:52

I uploaded the FreeCAD.log (64bit) and the 32bit file, but could not find any crash.dmp file.
Maybe this is because FreeCAD is not crashing but windows tells me it "stopped working" (roughly translated from german, so the actual wording could differ). then i can "kill" the programm or "wait for it to work again" which does nothing.

Also, the log files was located in:

i could also upload a video of me, recreating this crash, if this is helpful.


2014-04-07 16:51


FreeCAD 32bit.log (Attachment missing)


2014-04-07 16:59

administrator   ~0004542

A video would be cool.

But the "stopped working" usually means that there was a crash.


2014-04-07 17:14

reporter   ~0004543

Here you go:


2014-04-08 10:23

administrator   ~0004544

Thanks for the video.

With this version FreeCAD 0.14.3310_x64 I could reproduce this crash but not on my Linux box. I still have to check with latest master...

Also, it's true that it doesn't create the .dmp file. However, in the Windows Temp folder the system created a file WER1C6A.tmp.hdmp which shows this callstack which gives me a hint where to search:

     msvcr90.dll!_invalid_parameter() + 0x70 bytes
     msvcr90.dll!_invalid_parameter_noinfo() + 0x19 bytes
> PartGui.pyd!000007fee49da341()
     [Frames below may be incorrect and/or missing, no symbols loaded for PartGui.pyd]
     user32.dll!UserCallWinProcCheckWow() + 0x11d bytes
     user32.dll!DispatchMessageWorker() + 0x12a bytes


2014-04-08 11:58

administrator   ~0004545

I could confirm this crash also with the latest developer version. However, it has nothing to do with adding the Move command to the Part workbench. This also happens when using it from the Draft workbench.


2014-04-08 13:08

reporter   ~0004546

If i can help you in any way, let me know.


2014-04-08 15:10

administrator   ~0004547

It's fixed now.

Related Changesets

FreeCAD: master 78b24c9b

2014-04-08 13:59:22


Details Diff
+ fixes# 0001502: crash when using 'move' tool in part workbench Affected Issues
mod - src/Mod/Part/Gui/SoBrepEdgeSet.cpp Diff File

Issue History

Date Modified Username Field Change
2014-04-07 10:56 Fleder New Issue
2014-04-07 12:34 wmayer Note Added: 0004538
2014-04-07 15:42 Fleder Note Added: 0004539
2014-04-07 15:44 Fleder Note Edited: 0004539
2014-04-07 16:35 wmayer Note Added: 0004540
2014-04-07 16:45 Fleder File Added: FreeCAD.log
2014-04-07 16:48 Fleder Note Added: 0004541
2014-04-07 16:49 Fleder Note Edited: 0004541
2014-04-07 16:50 Fleder Note Edited: 0004541
2014-04-07 16:51 Fleder File Added: FreeCAD 32bit.log
2014-04-07 16:52 Fleder Note Edited: 0004541
2014-04-07 16:59 wmayer Note Added: 0004542
2014-04-07 17:14 Fleder Note Added: 0004543
2014-04-08 10:23 wmayer Note Added: 0004544
2014-04-08 11:58 wmayer Note Added: 0004545
2014-04-08 13:08 Fleder Note Added: 0004546
2014-04-08 15:09 wmayer Changeset attached => FreeCAD Master master 78b24c9b
2014-04-08 15:10 wmayer Note Added: 0004547
2014-04-08 15:10 wmayer Status new => closed
2014-04-08 15:10 wmayer Assigned To => wmayer
2014-04-08 15:10 wmayer Resolution open => fixed
2014-04-08 15:10 wmayer Fixed in Version => 0.14