View Issue Details

IDProjectCategoryView StatusLast Update
0004332FreeCADBugpublic2021-02-07 21:23
ReporterAlStu Assigned To 
Status newResolutionopen 
PlatformAcer Aspire V, 8GB/512GB SSDOSWindowsOS Version10 Home, kept up
Target Version0.20 
Summary0004332: Thickness limitation on curved geometry
DescriptionOn file 04-29b, Thickness works well: It is a boat Body with longitudinal symmetry. On PartDesign WB, it is made by lofting through 3 sketches. The sketches are on the same XZ plane but displaced by Y and Z Attachments. Each sketch has 3 lines and an arc. Thickness is Reversed true and Intersection true.

On file 04-29c, Thickness fails: The Body is identical to above except that on 1 ("Rib mid") of the 3 sketches, 2 lines have been replaced by very shallow arcs. The arcs are so shallow that they visually appear straight. In more detail, Thickness works up to 3.60mm and fails at 3.70mm and above. The Report says "<App> Document.cpp(3715): Failed to recompute Nonsuch_04_29c#Thickness: BRep_API: command not done".

I first asked on the forum here and was told to change from v0.18 to v0.19 and that worked for the file 04-29b. I later asked on the forum here and have not had a reply. I used PartDesign WB but still fails on Part WB. I have tried many variations in the geometry and settings, none improve the 3.60mm max Thickness limitation, most cause complete failure.
Steps To ReproduceBecause of the sweeping shape of the curves involved to create this issue, easiest to just test on the attached files, 04-29c is the one which fails. They have already had AdditiveLoft. Select Face 2 (the top face) and try to Make a Thick Solid tool above 3.60mm.
Additional InformationMy fallback would be to make a plug and use binary subtraction, but that is a pain and the Thickness limitation will still exist.
TagsNo tags attached.
FreeCAD InformationOS: Windows 10 (10.0)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.20655 (Git)
Build type: Release
Branch: master
Hash: e8e67e8c5ebbc9f9ed9ea67aba5b891969595ece
Python version: 3.8.2
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: English/Canada (en_CA)



2020-05-01 16:17


Nonsuch 04-29b.FCStd (253,437 bytes)
Nonsuch 04-29c.FCStd (292,874 bytes)


2020-06-07 10:43

reporter   ~0014492

Thickness is becoming unusable, always saying "BRep_API: command not done" or "BRep_Tool:: TopoDS_Vertex hasn't gp_Pnt" even with very small thickness eg 0.1mm


2020-06-07 13:18

reporter   ~0014494

Here is the most simple geometry demonstrating thickness fail.
Try to make a thickness, selecting the face with no fillet to get a simple cap results in "BRep_API: command not done"
bug_thikness.FCStd (22,731 bytes)


2021-02-07 21:23

administrator   ~0015301

For the record, this is still failing for me with OCC 7.5:
OS: Windows 10 Version 2004
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.23971 (Git)
Build type: Debug
Branch: master
Hash: a3fb41502b079a86175e6a414d82956a48bab4e2
Python version: 3.8.6+
Qt version: 5.15.1
Coin version: 4.0.1
OCC version: 7.5.0
Locale: English/United States (en_US)


2022-03-03 13:55

administrator   ~0016889

This ticket has been migrated to GitHub as issue 6055.

Issue History

Date Modified Username Field Change
2020-05-01 16:17 AlStu New Issue
2020-05-01 16:17 AlStu File Added: Nonsuch 04-29b.FCStd
2020-05-01 16:17 AlStu File Added: Nonsuch 04-29c.FCStd
2020-06-07 10:43 sfornengo Note Added: 0014492
2020-06-07 13:18 sfornengo Note Added: 0014494
2020-06-07 13:18 sfornengo File Added: bug_thikness.FCStd
2021-02-06 06:49 abdullah Target Version => 0.20
2021-02-07 21:23 chennes Note Added: 0015301