View Issue Details

IDProjectCategoryView StatusLast Update
0004803SpreadsheetBugpublic2021-12-30 03:55
Reporterroipoussiere Assigned Tochennes  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformLinuxOSKubuntuOS Version20.04
Product Version0.19 
Fixed in Version0.20 
Summary0004803: spreadsheet: the alias content is not visible (black on black)
DescriptionThe "content" textbox content is displayed with white color, but the "alias" textbox content is displayed with black color, so it's not really visible. See image attached.

I use a dark theme on my system btw.
Additional InformationOS: Ubuntu 20.04.3 LTS (KDE/plasma)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.24291 (Git) AppImage
Build type: Release
Branch: (HEAD detached at 0.19.2)
Hash: 7b5e18a0759de778b74d3a5c17eba9cb815035ac
Python version: 3.8.8
Qt version: 5.12.9
Coin version: 4.0.0
OCC version: 7.4.0
Locale: French/France (fr_FR)
TagsNo tags attached.

Activities

roipoussiere

2021-12-11 23:08

reporter  

image.png (10,285 bytes)   
image.png (10,285 bytes)   

chennes

2021-12-29 03:12

administrator   ~0016135

This is happening because a QPalette is being used to set the text color to either "red" in the case of an error, or "black" in the case of no error. Obviously "black" should be replaced by "the original color".

chennes

2021-12-30 03:55

administrator   ~0016170

This is fixed by commit 4098c8817.

Issue History

Date Modified Username Field Change
2021-12-11 23:08 roipoussiere New Issue
2021-12-11 23:08 roipoussiere File Added: image.png
2021-12-11 23:10 roipoussiere OS Version 20 => 20.04
2021-12-13 03:36 chennes Project Addon Manager => Spreadsheet
2021-12-13 03:36 chennes Assigned To => chennes
2021-12-13 03:36 chennes Status new => assigned
2021-12-29 03:12 chennes Status assigned => confirmed
2021-12-29 03:12 chennes Note Added: 0016135
2021-12-30 03:55 chennes Status confirmed => resolved
2021-12-30 03:55 chennes Resolution open => fixed
2021-12-30 03:55 chennes Fixed in Version => 0.20
2021-12-30 03:55 chennes Note Added: 0016170