View Issue Details

IDProjectCategoryView StatusLast Update
0000645FreeCADBugpublic2012-04-10 16:32
Reporterpeepsalot Assigned To 
Status closedResolutionfixed 
Fixed in Version0.13 
Summary0000645: Mesh.Mesh returns empty mesh when provided integers
DescriptionI was experimenting with mesh scripting, and made a simple script for displaying a "handmade" tetrahedron. But when I ran the script the mesh was not displayed in the document. It took me quite a bit of time to figure out what was going on, but it appears that passing integers for vertex coordinates results in an empty mesh. Once I rewrote this to pass in floats, it worked as expected.

Attached is a script with two methods, the first provides a list of faces to Mesh.Mesh in the form of integers, and the second in the form of floats. The first one results in an empty mesh, while the second succeeds.

Mesh: [0 Faces, 0 Edges, 0 Points]
Mesh: [4 Faces, 6 Edges, 4 Points]

Mesh should be able to accept integers as input, or at least throw a warning/error or something if it fails to add these vertices.
Additional InformationUbuntu 11.10 64 bit
FreeCAD 0.13 git 0674
TagsNo tags attached.
FreeCAD Information


2012-03-17 08:25 (Attachment missing)


2012-04-10 16:32

administrator   ~0001923

In git 7d54d0303449093bcb2697e4265582aa751125f1

Issue History

Date Modified Username Field Change
2012-03-17 08:25 peepsalot New Issue
2012-03-17 08:25 peepsalot File Added:
2012-04-10 16:32 wmayer Note Added: 0001923
2012-04-10 16:32 wmayer Status new => closed
2012-04-10 16:32 wmayer Resolution open => fixed
2012-04-10 16:32 wmayer Fixed in Version => 0.13