View Issue Details

IDProjectCategoryView StatusLast Update
0000071FreeCADBugpublic2010-02-08 13:26
Reporterwmayer Assigned Towmayer  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Summary0000071: Err: Cannot save BRep file '/tmp//....'
TagsNo tags attached.
FreeCAD Information


2010-02-06 09:25


bad-file.fcstd (Attachment missing)

2010-02-06 09:27


clean-file.fcstd (Attachment missing)

2010-02-07 14:39


corrupt-file-after-5-saves.fcstd (Attachment missing)


2010-02-07 14:44

administrator   ~0000168

Okay, I could reproduce now.
I open the clean-file.fcstd, and save it 5 times. The fifth time, it produces the corrupt-file-after-5-saves.fcstd in attachment, but doesn't yeld any error. That files has its brep files damaged, but not all of them.
The sixth time it produces the bad-file.fcstd and returns the "Cannot save BRep file '/tmp//....' " error. I tried doing stuff between the saves, drawing objects, etc, it always happens at the fifth save. But it might be specific to my computer (memory size, etc)... Can someone else test this?


2010-02-07 19:20

administrator   ~0000170

New test, that behaviour only happens on my debian system, not on windows... But there are well a couple of problems on windows too, after drawing a few more lines and a few more saves, some of the new objects are not saved in the file.
But at least the file is valid...
I'll test on a third system to see if there is any other difference.


2010-02-08 13:15

administrator   ~0000171

Yes, I can confirm the behaviour. On Debian after saving five times some breps are empty on Windows this error doesn't occur.

Additionally, I got this error message for all objects:
"ViewProviderPythonFeature::attach: 'Gui.ViewProviderPythonFeature' object has no attribute 'FontName'"


2010-02-08 13:20

administrator   ~0000172

After doing some tests I found out that the tmp. files where to save the data even couldn't be created. ATM for every shape we save we create a unique filename (under /tmp).

It seems that there is somehow an internal limit inside Linux because when using the same tmp. filename again and again everything seems to be fine again.


2010-02-08 13:26

administrator   ~0000173

I think rev. 2918 fixes this bug.

Issue History

Date Modified Username Field Change
2010-02-06 09:25 wmayer New Issue
2010-02-06 09:25 wmayer Status new => assigned
2010-02-06 09:25 wmayer Assigned To => wmayer
2010-02-06 09:25 wmayer File Added: bad-file.fcstd
2010-02-06 09:27 wmayer File Added: clean-file.fcstd
2010-02-07 14:39 yorik File Added: corrupt-file-after-5-saves.fcstd
2010-02-07 14:44 yorik Note Added: 0000168
2010-02-07 19:20 yorik Note Added: 0000170
2010-02-08 13:15 wmayer Note Added: 0000171
2010-02-08 13:20 wmayer Note Added: 0000172
2010-02-08 13:26 wmayer Note Added: 0000173
2010-02-08 13:26 wmayer Status assigned => closed
2010-02-08 13:26 wmayer Resolution open => fixed