View Issue Details

IDProjectCategoryView StatusLast Update
0004116FreeCADBugpublic2021-02-11 17:35
ReporterOnearm Assigned To 
Status closedResolutionno change required 
PlatformfreeCAD 18.0OSManjaro Gnome OS Version17
Target Version0.20 
Summary0004116: Icons on page massive and take up 80% of the work area
DescriptionI am completely new to FreeCAD, so find this very frustrating. The icons a huge and I cannot find where to change them
I am running an HP Pavilion with 8 Gig RAM, Radeon 5 2T hard drive.
Could it be a conflict as Nvidia display adapter is also installed
Steps To ReproduceNew file page
TagsNo tags attached.
FreeCAD Information


related to 0003498 closed Preference categories not showing up if specific workbench has not been visited 



2019-09-06 00:17



2019-09-06 00:21

reporter   ~0013549

This is a better shot


2019-09-06 08:48

developer   ~0013551

@Onearm : please go according the preferred workflow (big yellow box on top of the page) and especially first open a topic in the forum to get help from community and eventually confirm if there is a bug here or not (and if it's a FreeCAD one). ;)


2019-10-20 15:14

administrator   ~0013770

@Onearm what does you Preferences > General > General > Size of toolbar icons


2019-10-20 16:20

reporter   ~0013773

Last edited: 2019-10-20 16:23

Thanks Kunda1 for getting back to me. I wasted so much time with the issue I gave up and changed to Cinnamon, where the FreeCad installation made the system crash. So I am looking for alternative CAD packages.
The response I got from openBrain was in my view a waste of time, as Aussies say, 'as useless as tits on a bull'. If people are so up themselves, rather don't bother commenting! Bear in mind you were a beginner once too.


2019-10-20 16:40

developer   ~0013774

@Onearm : could you point to the forum topic you opened for this problem ?


2019-10-21 00:09

administrator   ~0013776

@Onearm well to our credit and openBrain's defense, we do have a ginormous banner at the top of the page orienting people on what the most optimal action they should take to get their issue addressed, and that is for users to open forum thread.

FreeCAD has a very active community and very long release cycle, many issues are fixed in the development versions. Also, because of the many dependencies that FC has, it's best to either use an distro that has it's package repository up to date or use the AppImage. Even Manjaro (my favorite distro), an Arch derivative, doesn't have a solid stable FreeCAD version due to some dependency SNAFUs. There is also no legit 0.19dev version (which i would recommend to use instead of 0.18.x). But if you've moved on, then you've moved on. c'est la vie


2019-10-21 00:10

reporter   ~0013777

I usually use the word please before a request!


2019-10-21 03:33

reporter   ~0013778

Hi Kunda1, yes, I tried release 0.18.xx and that is what caused the crash. I tried installing with AppImage as well as Snapd both problematic
It may be worth while listing the distros that FreeCad does works on, so simple people like me, can see what to use and what not to use. This would save a lot of frustration for us new comers.You would be in a good position to do this, as you would soon see which distro is giving you he most 'grief'. So my question would be, which is the best distro for FreeCad?
While ditching Windows and trying to come to grips with basic Linux at this stage of life is difficult enough, because many of us have not done any coding or scripting for many years other than very simple DOS 30 years ago, having issues like this is a big turn-off. Getting rude and unhelpful responses adds to that.
Yes, you do have a big yellow box at the top, however it could be put in a better way. Because you do not record every move you make while trying to get something up and running, it is very difficult to retrace your steps.
Thanks for your help!


2019-10-21 14:51

developer   ~0013780

@Onearm : when we talk about forum, it's FreeCAD forum. ;) You'd probably get more valuable answers there.
Listing working distros isn't so simple. For example (IIRC), @Kunda1 also uses Manjaro w/o any problem. I myself use Kubuntu if you want to give it a try.
Notice that I used 'please' on my 1st note, then as in a discussion it doesn't seem mandatory to me. Also 'could' looks to me as some kind of politeness. And finally please remember that not everybody here is a native english speaker. ;)


2019-10-21 15:20

reporter   ~0013782

Thanks openBrain, I have just been searching the forum but didn't find anything of use.
I find it hard enough getting familiar with Manjaro Cinnamon, Gnome gave a lot of problems so ditched that. Don't want to keep hopping around as it is too time consuming, so would like to find one that works for sure and stick with it to learn the rest. Cheers.


2019-10-27 10:49

administrator   ~0013793

@Onearm here's the thing, we want to help you but there has been miscommunication somehow. So I'll give you a little context, please understand that FreeCAD can run on multiple operating system and within Linux can run on multiple distros. Each of these environments require tweaks of some sort because they all are unique in their own way. FreeCAD is a complex application from an infrastructure point of view. It depends on many 3rd party dependencies (some of which it bundles in to it's source code and others that it calls externally at build time). As you can see this is a monumental task in itself.

We're still offering to help but you need to also have the patience and perseverance to learn this program that is being developed by volunteers from all over the world, for free. Again, the best way for us to help you, is if you to open a post on our forums and start participating. A ticket on the tracker is not the way to receive support from our community. If you choose not to move forward with your query, then that's Ok as well. Please let us know what you'd like to do so we can ascertain the status of this ticket. Thanks


2019-12-05 14:59

administrator   ~0013869

@Onearm care to follow up


2019-12-12 14:37

reporter   ~0013906

Hi @Kunda1, sorry for the delay in getting back to you, unfortunately had to rush back to South Africa for my brother's funeral.
I have now had a bash at reinstalling FreeCAD using Appimage, and it seems to have worked this time. At least there aren't the huge icons!
Now the learning starts. I have used Sketchup quite a bit in the past,certainly no expert, but got the drawings I needed for steel fabrication done. I'll be good to see if I can get the hang of FreeCAD. Unfortunately, as my logon suggests, I can only use my right hand, so most of the short cut keys are out of the question for me, unless I can reprogram them.You may have some suggestions in that regard.
Thanks for the followup anyway!

Issue History

Date Modified Username Field Change
2019-09-06 00:17 Onearm New Issue
2019-09-06 00:17 Onearm Tag Attached: Huge icons on work display
2019-09-06 00:17 Onearm File Added: Screenshot Freecad working window from 2019-09-05 20-32-52.png
2019-09-06 00:21 Onearm File Added: Screenshot from 2019-09-06 07-18-12.png
2019-09-06 00:21 Onearm Note Added: 0013549
2019-09-06 08:48 openBrain Note Added: 0013551
2019-09-06 08:50 openBrain Tag Detached: Huge icons on work display
2019-09-06 08:50 openBrain Tag Attached: #post-to-forum
2019-09-06 08:51 openBrain Severity major => tweak
2019-09-06 08:51 openBrain Status new => feedback
2019-10-20 15:14 Kunda1 Note Added: 0013770
2019-10-20 16:20 Onearm Note Added: 0013773
2019-10-20 16:20 Onearm Status feedback => new
2019-10-20 16:23 Onearm Note Edited: 0013773
2019-10-20 16:40 openBrain Note Added: 0013774
2019-10-21 00:09 Kunda1 Note Added: 0013776
2019-10-21 00:10 Onearm Note Added: 0013777
2019-10-21 03:33 Onearm Note Added: 0013778
2019-10-21 14:51 openBrain Note Added: 0013780
2019-10-21 15:20 Onearm Note Added: 0013782
2019-10-27 10:49 Kunda1 Note Added: 0013793
2019-10-28 17:34 Kunda1 Status new => feedback
2019-12-05 14:59 Kunda1 Note Added: 0013869
2019-12-12 14:37 Onearm Note Added: 0013906
2019-12-12 14:37 Onearm Status feedback => new
2020-01-11 13:38 Kunda1 Relationship added related to 0003498
2021-02-06 06:49 abdullah Target Version => 0.20
2021-02-11 17:34 Kunda1 Status new => closed
2021-02-11 17:34 Kunda1 Resolution open => no change required
2021-02-11 17:35 Kunda1 Tag Detached: #post-to-forum