View Issue Details

IDProjectCategoryView StatusLast Update
0004495FreeCADBugpublic2021-03-30 02:30
Reporteruwestoehr Assigned Touwestoehr  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Target Version0.20 
Summary0004495: Navigation cube is not clickable at its edges and corners
DescriptionWhen clicking on the edge of the navigation cube (the chamfered area), the view should be rotated by 45°.
This does not work. One can select the area but it turns the view by 90°. Here is an example:
Additional InformationForum thread: https://forum.freecadweb.org/viewtopic.php?f=3&t=52118
Tags#tobeclosed
FreeCAD InformationOS: Windows 10 (10.0)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.23029 (Git)
Build type: Release
Branch: master
Hash: 691f25904218e923d1cd70ab72743c40f9bb36c5
Python version: 3.6.8
Qt version: 5.12.6
Coin version: 4.0.0a
OCC version: 7.4.0.beta
Locale: German/Germany (de_DE)

Activities

uwestoehr

2020-11-16 11:25

manager   ~0014991

Here is how the OCC NaviCube behaves:



This is a screencast from CAD Builder, so OCC's NaviCube works as expected, the bug is in FreeCAD.

uwestoehr

2021-02-21 14:05

manager   ~0015416

Here is a PR that adds the missing clickable edge faces: https://github.com/FreeCAD/FreeCAD/pull/4502

Work is in progress

Kunda1

2021-03-29 17:00

administrator   ~0015574

FreeCAD master e58ee299
FreeCAD master 23747f9d
FreeCAD master f525904c

Kunda1

2021-03-29 17:01

administrator   ~0015575

@uwestoehr can this ticket be closed?

uwestoehr

2021-03-30 02:30

manager   ~0015585

Fixed in master

Related Changesets

FreeCAD: master e58ee299

2021-02-21 05:16:09

uwestoehr


Committer: wmayer Details Diff
[Gui] improving NaviCube

fixes bug 4495

- add missing edge faces
- implement a proper rotation recipe -> rotate towards the nearest possible state
- add preferences settings to turn off this new rotation behavior
- get rid of transparent cube faces to avoid wrong clicks, this way also remove the backfaces
- to make the edge faces fit, use triangles for the corners
- expose cube size setting to preferences dialog
- add new button to view backside
- get rid of bitmaps because as reported in https://forum.freecadweb.org/viewtopic.php?f=3&t=52118&start=20#p481781
the x y z labels are not scaled on HiDPI screens
moreover they are often "in they way" when you want to click on a corner and in principle they don't provide more info since we already have the CS with the axis labels

- also fix an arithmetic overflow compiler warning
- also rename 2 variables
Affected Issues
0004495
mod - src/Gui/DlgSettingsNavigation.cpp Diff File
mod - src/Gui/DlgSettingsNavigation.ui Diff File
mod - src/Gui/NaviCube.cpp Diff File

FreeCAD: master 23747f9d

2021-03-27 22:20:59

uwestoehr


Committer: wmayer Details Diff
fix animation issue

SO's auto rotation has its own rotation logic that ends at fixed positions. This collides with the "to nearest" option whose aim is to rotate to the next sensible state taking into account from what position the rotation was started.

Thus the solution is to disable SO's auto rotation while the cube is rotated.
Affected Issues
0004495
mod - src/Gui/NaviCube.cpp Diff File

FreeCAD: master f525904c

2021-03-29 16:29:44

wmayer

Details Diff
Gui: concatenate rotations and apply the result once at the end Affected Issues
0004495
mod - src/Gui/NaviCube.cpp Diff File

Issue History

Date Modified Username Field Change
2020-11-16 01:23 uwestoehr New Issue
2020-11-16 11:25 uwestoehr Note Added: 0014991
2021-02-06 06:49 abdullah Target Version => 0.20
2021-02-21 14:05 uwestoehr Note Added: 0015416
2021-03-29 17:00 Kunda1 Note Added: 0015574
2021-03-29 17:00 Kunda1 Changeset attached => FreeCAD master e58ee299
2021-03-29 17:00 Kunda1 Changeset attached => FreeCAD master 23747f9d
2021-03-29 17:00 Kunda1 Changeset attached => FreeCAD master f525904c
2021-03-29 17:01 Kunda1 Note Added: 0015575
2021-03-29 17:02 Kunda1 Tag Attached: #tobeclosed
2021-03-30 02:30 uwestoehr Assigned To => uwestoehr
2021-03-30 02:30 uwestoehr Status new => resolved
2021-03-30 02:30 uwestoehr Resolution open => fixed
2021-03-30 02:30 uwestoehr Note Added: 0015585